MouseHunt AutoBot 1.28 in Google Chrome version 27 Problem and Solution

I have received lot of lot of comments regarding MouseHunt Autobot 1.28 no longer work in Facebook MouseHunt app running Google Chome. Actually I’m in a tight schedule developing my own project, but I have received a lot of comments which I no longer can ignore them. So I done some homework on what actually happen.

First of all, the script is still doing great (This surprise me). The MouseHunt game doesn’t change anything that affected the script too (If you run the script through Firefox, they are running smooth). So, the only thing left is the Google Chrome itself. Yes, some how Google Chrome version 27 no longer allow user scripts to run in iframe (MouseHunt in Facebook run in iframe) by default. In order to allow user scripts to run in iframe, an additional manifest need to be included together with the userscript. I find it very troublesome to distribute the user script in two separate files, so I ignored this option.

Meanwhile, Google Chrome rapid updates and changing causes installing user scripts which are not from Chrome Web Store much harder and problematic. I need to keep on updating my blog to follow their changes which is kind of a pain to me as well.

I found a much simple solution for all those problems. Use Tampermonkey extension in Google Chome instead (very similar to Greasemonkey add-on in Firefox). The extension automatically allow user script to run in iframe which solve the problem in Google Chrome version 27. Furthermore, with this extension, user can direct install user script from userscript.org which make user’s life much more easy as well. I have written a blog post on how you can install / uninstall user script in Google Chrome through Tampermonkey Extension. Remember to uninstall the MouseHunt AutoBot in the Google Chrome Extension to prevent multiple copies of MouseHunt AutoBot running at the same time.

By the way, the link to run Mousehunt Autobot without iFrame option is broken now. The MouseHunt developer prevent anyone running the game without the iFrame in Facebook. You might want to ignore this option or just run the game in MouseHunt official website instead.

I’m glad to see that there are still so many players support my script. Thanks. Although I’m busy, keep me posted if anything happen, I will try fix them as soon as possible.

 

by Ooi Keng Siang via Ooiks’s Blog

45 thoughts on “MouseHunt AutoBot 1.28 in Google Chrome version 27 Problem and Solution

  1. There is a problem with the bot again due to apple update in the quicktime player 7.74.80.86. After the update when the king’s reward is loaded there is no sound and it asks me to install quicktime plugin even when it has been installed and tested on other sites. I guess the temporary solution would be to use an older version of quicktime. Also i realised that on Mousehuntgame.com after botting for a period of time, the page will give me an ssl security error which screws up the bot and makes it stop. Appreciate any solution to this problem. Thanks

    Like

      1. There was another update in QuickTime and there is no sound, when KR shows up. Also it sometimes crashes Chrome in general – it can go to “program not responding mode”

        Like

  2. Hey man. Been a great fan of your mousehunt script for ages. Recently come across an issue where the page automatically redirects itself to the login.php page and the script stops working. (mousehuntgame.com) I was wondering it you have a solution to overcome this issue. There is also an issue where it redirects the page to say SSL security error and that stops the bot too. It will be a great help if you can give me any suggestions on how to stop this matters from occurring again thanks!

    Like

  3. *this reply is just so i can subscribe to your blog and be notified when there’s any new entries. SO don’t mind it*

    Like

  4. Before i read the comments, i uninstall, re-install browser, change from chrome to firefox, and then opera, go do all kind of trouble shoot and almost format my computer as i thought i was hit by a bug/virus/worm…
    i did all that as i thought i was the only one who encounter this problem (posted by Norman).
    turns out that it’s an apple problem.

    Ooik,
    i would really appreciate it if you can help to address this issue. (when you are free)
    my 4th mh anniversary is coming soon, and i find that i still like mh a lot. 🙂

    Like

  5. Hey man,

    I can’t get the king’s reward sound to work. I have quicktime installed but it just won’t play. I’m on a mac, so i can’t downgrade Quicktime. Hope you can find a fix. Thanks!

    Like

  6. Now the 7.71 version of Quick time player plugins cannot be supported and it crash when got King reward …. so Now no music come out already when king reward comes , please fix it or make quick time player version 7.74 ( newest version ) can be use….

    Like

  7. I have fixed my Kings Reward notification sound.
    I removed the version I had and then went and found old versions and loaded version 7.55.90.70 and the music has returned…….very happy…….:)

    Like

  8. hey thanks for the bot. But I am unable to access userscripts.org. Is there any other portal i can download it by any chance

    Like

    1. Hi try to check for latest update of chrome and then uninstall extension and reinstall by dragging the extension to chrome>extension. Worked for me tried last night

      Like

      1. Sorry could you kindly explain in more details what you mean? Which extension and where is the ‘chrome>extension” page?

        Like

      2. My chrome is the latest already and it works. But after a restart, the extensions get disabled and I have to reinstall them again.

        Like

      3. Yes I know that used to work for me also but not it doesn’t chrome is coming down hard on extensions not from chrome store. Pls follow my suggestion which works. 1) uninstall all the bots. 2) install tempermonkey from chrome store 3) enable the extension tempermonkey. 4) go to this website and press add to chrome. It will be added to tempermonkey http://userscripts.org:8080/scripts/show/78731
        After that just click on the extension tempermonkey and ensure the not is enabled by clicking on the red dot on your left. It should change to green and say enabled

        Like

  9. Hi I just re-installed my computer and my mousehunt autobot didn’t run. i’ve tried in any given website but still no luck. can anybody help me? I have installed everything that needed. I’m using firefox as my browser

    Like

    1. Sorry but for Firefox its different from chrome. I do not personally use Firefox so I am not 100% sure if its working but it should. Try downloading the rextension greasemonkey before attempting to download the userscipt for the mousehunt bot.

      Like

  10. The Bot stopped working today for me -.- I dont know whats going on but it will not work on Opera nor Firefox nor Chrome, any help will be well received -.- as I have the 1.28 scripts stored in my pc but cant get it to work, not even with the trapmonkey or whatever the name is. HELP!

    Like

    1. It’s tempermonkey. Pls read my above directions. It should work. Just uninstall all the bots and extension first. Yes I know that used to work for me also but not it doesn’t chrome is coming down hard on extensions not from chrome store. Pls follow my suggestion which works. 1) uninstall all the bots. 2) install tempermonkey from chrome store 3) enable the extension tempermonkey. 4) go to this website and press add to chrome. It will be added to tempermonkey http://userscripts.org:8080/scripts/show/78731
      After that just click on the extension tempermonkey and ensure the not is enabled by clicking on the red dot on your left. It should change to green and say enabled

      Like

  11. For all of those having problem, it seems that manually installing the extension by dragging to chrome> extension doesnt work after latest update. Hence i think the only solution is to add it by tempermonkey

    Like

  12. script sourced from greasyfork & installed in tampermonkey for chrome and enabled, but it is not working any more. It does not show up on the hunting page

    Like

  13. Mousehunt is currenlty having beta for new UI, i tried it but the autobot does not work in it, so i was hoping for updates regarding updated versions of the script

    Like

  14. Hey, first I just wanna say how I really appreciate what you’re doing. The script really helped me throughout the game. I just wanna ask about the Opera extension. I’ve don every single step you’ve posted and even downloaded the previous version of Opera because I thought the problem lies with the browser but so far nothing works and I am left without Autobot on my Opera mousehunting. Can you give me a solution? I’m really frustrated by this.

    Like

Leave a Reply

Fill in your details below or click an icon to log in:

WordPress.com Logo

You are commenting using your WordPress.com account. Log Out / Change )

Twitter picture

You are commenting using your Twitter account. Log Out / Change )

Facebook photo

You are commenting using your Facebook account. Log Out / Change )

Google+ photo

You are commenting using your Google+ account. Log Out / Change )

Connecting to %s